?
快捷搜索:  as  test  1111  test aNd 8=8  test++aNd+8=8  as++aNd+8=8  as aNd 8=8

龍都國際唯一網站:實戰OSPF的路由再分配

?

路由再分配涉及到將路由信息從某個源(平日是某種路由協議)發送到另一個源(平日是另一種路由協議)。

現在,我們來具體看看到底什么是路由再分配,讓我們來做一個實際的路由再分配的實驗。一種環境便是必要應用一些收集設備,而這些設備并不支持收集中的路由協議。

假如要用這些設備,必要把路由信息從設備中引入到你所在收集應用的路由協議中去。現在讓我們來對于這樣的環境,并反省每一種設備是否獲得了精確的設置設置設備擺設擺設。

假設,你所在的企業收集有一個防火墻,它僅僅支持路由信息協議,即Routing Information Protocol(RIP)。你盼望把這個防火墻作為收集的默認網關,然而,收集卻又運行著開放最短路徑優先協議,即Open Shortest Path First (OSPF)。

你若何才能把默認的RIP路由信息放到OSPF收集中去呢?謎底便是路由重分配。首先,現在先看看圖A所示的收集。

圖A

防火墻在圖的頂部,連接著路由器1.路由器1連著路由器2(在實際收集里面,還可能繼承連下去)。

路由器1便是我們的重分配點。在這里我們將對來自防火墻的RIP路由信息重分配,然后放入到OSPF收集中。是以,路由器1必要運行RIP和OSP龍都國際唯一網站F協議。即在連接防火墻的接口上運行RIP,在連接路由器2的接口上運行OSPF.

這一步停止后,我們必要不雅察路由器2的默認路由,最初這由防火墻設置完成。只有路由器1具備默認路由的時刻,路由器2才會有默認路由。這里異常緊張:只管你可以持續從路由器1發送默認路由到路由器2而無需應用重分配,你照樣必要使得路由器2具備默認路由。

下面便是路由器1的IP地址設置設置設備擺設擺設

interface Ethernet0

ip address 1.1.1.125 255.255.255.0

!

interface Serial0

ip address 2.2.2.1 255.255.255.0

路由器1的路由設置設置設備擺設擺設

router ospf 1

redistribute rip subnets

network 2.2.2.0 0.0.0.255 area 0

default-information originate

!

router rip

network 1.0.0.0

我們可以看到,路由器在串口上啟用了OSPF ,在以太口上啟用了RIP.此外,你必要留意下面這些敕令:

redistribute rip subnets:

在OSPF路由歷程中,該敕令將把任何應用RIP協議收集收到的路由信息發給OSPF.subnet關鍵字高速路由器對所有收集(包括子網)進行重分配。按照默認設置,該敕令將會僅僅對標準收集重分配。

default-information originate:

在OSPF路由歷程中,該敕令將容許OSPF廣播默認路由。按照默認設置,該敕令將僅僅對切實著實存在的獨一默認路由進行廣播。然而,你也可以在敕令末端應用always關鍵字提示路由器經由過程OSPF廣播默認路由,而不管路由到底是不是獨一存在的。

現在,來看看路由器2的IP地址設置設置設備擺設擺設:

interface Ethernet0

ip address 10.1.1.1 255.255.255.0

!

interface S龍都國際唯一網站erial0

ip address 2.2.2.2 255.255.255.0

clockrate 250000

這是路由器2的路由設置設置設備擺設擺設:

router ospf 1

network 10.1.1.0 0.0.0.255 area 0

network 2.2.2.0 0.0.0.255 area 0

留意路由器2僅僅運行OSPF.

接下來,讓我們在路由器1上運行show ip route敕令。下面便是輸出結果:

R1# show ip route

Codes:

C - connected, S - static, R - RIP, M - mobile, B?BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA e龍都國際唯一網站xternal type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

Gateway of last resort is 1.1.1.126 to network 0.0.0.0

1.0.0.0/24 is subnetted, 1 subnets

C 1.1.1.0 is directly connected, Ethernet0

2.0.0.0/24 is subnetted, 1 subnets

C 2.2.2.0 is directly connected, Serial0

10.0.0.0/24 is subnetted, 1 subnets

O 10.1.1.0 [110/74] via 2.2.2.2, 00:13:19, Serial0

R* 0.0.0.0/0 [120/1] via 1.1.1.126, 00:00:03, Ethernet0

留意,路由器1經由過程RIP接管到了默認路由,正如輸出信息著末面僅靠0.0.0.0/0默認路由的R標志所表示的那樣。你還必要留意,路由器1和路由器2經由過程OSPF通信。由于路由器1對路由器2上的以太網有10.1.1.0/24這條路由。

現在在路由器2上運行show ip route,結果如下:

R2# show ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B?BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

E1 - OSPF exter龍都國際唯一網站nal type 1, E2 - OSPF external type 2, E?EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route

Gateway of last resort is 2.2.2.1 to network 0.0.0.0

1.0.0.0/8 is subnetted, 1 subnets

O E2 1.1.1.0 [110/20] via 2.2.2.1, 00:12:39, Serial0

2.0.0.0/8 is subnetted, 1 subnets

C 2.2.2.0 is directly connected, Serial0

10.0.0.0/8 is subnetted, 1 subnets

C 10.1.1.0 is directly connected, Ethernet0

O*E2 0.0.0.0/0 [110/1] via 2.2.2.1, 00:12:31, Serial0

R2#

留意,路由器2有指向路由器1的0.0.0.0/0默認路由(本例中即2.2.2.1),并且路由信息帶有O標志,即表示這是OSPF路由。

這是一條外部OSPF路由,正如E2標志所示。這注解路由的原并不是OSPF路由,而是另一種路由協議重分龍都國際唯一網站配而來。

路由器2并沒有RIP路由,由于它并沒有運行RIP.然則,經由過程重分配,路由器2能夠接管防火墻所廣播的RIP路由。

免責聲明:以上內容源自網絡,版權歸原作者所有,如有侵犯您的原創版權請告知,我們將盡快刪除相關內容。

您可能還會對下面的文章感興趣:

浙江体彩20选5开奖号 股票配资系统 赶牛网配资 四川熊猫麻将软件下 广东闲来麻将微信版 新贵州十一选五走势 赛车如何看单双大小 360中超直播 炒股的app tcl股票 诚飞财富配资 金鼎智富 贵阳麻将 4场进球彩复式 国际足球友谊赛直播 重庆快乐10分什么时候开奖 快乐真人麻将娱乐场斗地主